Display problems using ultra HD 4K monitor

Report bugs/issues with the Muso software. Fixed issues will be archived.

Display problems using ultra HD 4K monitor

Postby steveoat87 » Mon Oct 02, 2017 8:55 pm

I just bought a 43" Ultra 4K HD TV monitor which I am also using as a computer monitor.

However, muso seems to shrink so much that I can barely see anything.

When I restart it appears to work fine, but when I play some music, the screen shrinks so that I can barely see anything -- it appears to shrink to about 10% of the size it was.

any suggestions?
steveoat87
 
Posts: 49
Joined: Thu Aug 31, 2017 5:55 pm

Re: Display problems using ultra HD 4K monitor

Postby musoware » Mon Oct 02, 2017 11:03 pm

It's probably DPI scaling, if you set it to 100% for your primary monitor it should work fine - see viewtopic.php?f=4&t=447&p=3285#p3285
musoware
Site Admin
 
Posts: 1705
Joined: Fri Sep 14, 2012 6:50 am

Re: Display problems using ultra HD 4K monitor

Postby steveoat87 » Mon Oct 02, 2017 11:13 pm

Kind of defeats the purpose of having an ultra 4K monitor.

Any chance of fixing in future, using newest version of NET?
steveoat87
 
Posts: 49
Joined: Thu Aug 31, 2017 5:55 pm

Re: Display problems using ultra HD 4K monitor

Postby musoware » Tue Oct 03, 2017 7:02 am

I can't fix it, it's a .NET bug, but I'll review whether they have.

Is your 4k monitor your primary or only monitor?
musoware
Site Admin
 
Posts: 1705
Joined: Fri Sep 14, 2012 6:50 am

Re: Display problems using ultra HD 4K monitor

Postby steveoat87 » Tue Oct 03, 2017 3:30 pm

Yes, it is my only monitor.
steveoat87
 
Posts: 49
Joined: Thu Aug 31, 2017 5:55 pm

Re: Display problems using ultra HD 4K monitor

Postby musoware » Wed Oct 04, 2017 10:28 am

I have got a newer .NET version for you to trial, here: http://musoware.com/muso_deploy/SetupMusoDPI.msi
They did provide some help for developers to work around DPI issues, so I've addressed some of the issues, others are resolved by .NET itself it seems.
Any issues give me a shout, if it's OK I'll make this the official version.

If you've previously used the standalone installer this will update it, if you've been using the web installer this will be installed along-side, and will appear onthe menu like this:

Screenshot (3).png
Screenshot (3).png (5.12 KiB) Viewed 842 times


This will probably only work ( at least for DPI settings over 96 (100%)) on Windows 10, so I'd also be interested if anyone can try it on older OS's.
musoware
Site Admin
 
Posts: 1705
Joined: Fri Sep 14, 2012 6:50 am

Re: Display problems using ultra HD 4K monitor

Postby steveoat87 » Wed Oct 04, 2017 3:41 pm

I installed the latest NET that you provided, and updated Muso.

However, this does not work. I am getting an incredibly small image (scaling 200%). See attachment. Muso is unusable on my ultra 4K monitor.

Any suggestions?
Attachments
Muso screen revised.png
steveoat87
 
Posts: 49
Joined: Thu Aug 31, 2017 5:55 pm

Re: Display problems using ultra HD 4K monitor

Postby musoware » Wed Oct 04, 2017 3:53 pm

Do you mean the text is small? It looks like you have maximised Muso looking at its relation to the bottom icons. Use control-Plus to increase font size. Other than font size, what is not working with this version?
musoware
Site Admin
 
Posts: 1705
Joined: Fri Sep 14, 2012 6:50 am

Re: Display problems using ultra HD 4K monitor

Postby steveoat87 » Wed Oct 04, 2017 4:04 pm

Whats weird is that when I first open Muso, it looks normal. However, when I refresh gallery, the whole screen shrinks as above. This happened before and after I installed the new .net.

I will try to increase font size using control plus and report back. However, why does the whole screen shrink when I refresh gallery?
steveoat87
 
Posts: 49
Joined: Thu Aug 31, 2017 5:55 pm

Re: Display problems using ultra HD 4K monitor

Postby musoware » Wed Oct 04, 2017 4:07 pm

That was the bug in .net that was supposedly fixed in .net 4.7 - it was for me when i increased my dpi. Can you make sure you have that installed via the link below?

https://www.microsoft.com/en-us/downloa ... x?id=55170

Also please confirm the version of muso that is showing on Help/About - you could be running the old version if you didn't select the option from the meu that I highlighted.
musoware
Site Admin
 
Posts: 1705
Joined: Fri Sep 14, 2012 6:50 am

Next

Return to Bugs/Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron