Machine ID Changes With Every Update

Fixed bugs will be filed here.

Re: Machine ID Changes With Every Update

Postby musoware » Wed Sep 07, 2016 7:42 am

I don't understand why the licence is still being lost on upgrade. Is there not something in the log that says "Get isolated storage" or "Licensing"? It's the few lines after that I need. I'll also look at why diagnostics mode is being lost after upgrade.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Wed Sep 07, 2016 9:53 pm

On a second PC I allowed muso to update, with the same result.
After the update logging had been disabled, the Machine ID was retained, but the license was blank.
I reactivated logging, and have emailed the log file to you.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby musoware » Wed Sep 07, 2016 11:07 pm

I think I fixed the issue with the diagnostics mode being persisted through an update, which should (on the NEXT update after this one!) allow you to capture a new log for me which might reveal the issue with the licence key being lost - it still has me puzzled why it's doing that while retaining machine ID. Let me know when this version (2.5.25.4) is installed, turn on diagnostics and close, then I'll push another update to you to test it.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Wed Sep 07, 2016 11:24 pm

Have now updated to V2.5.25.4 - I have turned on diagnostic logging and reapplied the license.
I have emailed the log file to you.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby DuLac » Thu Sep 08, 2016 8:57 am

Jeremy, I am enclosing a log file. I kept the diagnostics going. After updating to 2.5.25.4 the issue of the licence being lost with an upgrade reappeared.
Attachments
muso2.rar
(5.76 KiB) Downloaded 225 times
DuLac
 
Posts: 205
Joined: Sun Feb 10, 2013 9:53 am

Re: Machine ID Changes With Every Update

Postby musoware » Thu Sep 08, 2016 10:31 am

DuLac wrote:Jeremy, I am enclosing a log file. I kept the diagnostics going. After updating to 2.5.25.4 the issue of the licence being lost with an upgrade reappeared.


I haven't attempted a fix for that yet, this patch was to (hopefully) persist diagnostic logging across an upgrade so we can capture what's happening when it DOES lose the licence.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby musoware » Thu Sep 08, 2016 9:33 pm

I've replicated your issue on a Windows 10 VM that I have, so that's promising, I'm no nearer to finding an answer though - I'll look more tomorrow.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Thu Sep 08, 2016 9:39 pm

Jeremy, thanks for this. I will await your fix.
Regards, Rob
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby DuLac » Sat Sep 10, 2016 4:22 pm

Although still no mention of this version in the forum news, Muso just finished upgrading to 2.5.26. I had to reenter my licence details as with the previous version.
Attachments
muso2_2_5_26.rar
(9.59 KiB) Downloaded 192 times
DuLac
 
Posts: 205
Joined: Sun Feb 10, 2013 9:53 am

Re: Machine ID Changes With Every Update

Postby musoware » Sat Sep 10, 2016 5:23 pm

Yeah sorry about that. Just released 2.5.27 which should hopefully fix this issue once and for all. You may have to enter your licence credentials one last time after upgrading to 2.5.27, but after that it should persist across updates.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

PreviousNext

Return to Fixed (Archived)

Who is online

Users browsing this forum: No registered users and 1 guest

cron