Machine ID Changes With Every Update

Fixed bugs will be filed here.

Re: Machine ID Changes With Every Update

Postby sonata » Mon Sep 05, 2016 11:17 pm

Well it is at that point that I am having trouble. When it updates itself, then the Machine ID changes after the update. But if I download from the website, the update does not change the Machine ID. So I guess I am still confused, but am still able to update OK from the website.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby musoware » Tue Sep 06, 2016 6:43 am

Download what from the website? The link that says "Download" or the link that says "standalone installer here"?

If it's the download link that should be exactly the same as allowing the software to update itself.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Tue Sep 06, 2016 6:54 am

When I clicked on the "Download" link on the muso website earlier today, I did not have a problem with the licenses. In one case the license was retained, and with the other 2 PC's, a Machine ID was displayed that I had seen previously - so I re-used the licenses associated with those Machine ID's.

But prior to using this method, I found that the auto-update method would result in a new Machine ID.

To do further testing, I guess I will have to wait until there is another update.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby musoware » Tue Sep 06, 2016 6:57 am

OK I have found a technical document which may explain why this is happening for you - what's more puzzling is why it's not happening for me, and presumably many others who haven't reported this issue, or why it's not also happening when you use the Download link. I'll be working on a possible fix...
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby DuLac » Tue Sep 06, 2016 12:22 pm

To make more confusing please note that I uninstalled and reinstalled Muso. Since then I've launched Muso some 5 times and apparently all is OK now.
DuLac
 
Posts: 205
Joined: Sun Feb 10, 2013 9:53 am

Re: Machine ID Changes With Every Update

Postby musoware » Tue Sep 06, 2016 11:32 pm

I've upgraded with a patch - you may have to enter the licence key once more after this, I'm not sure, but hopefully not again on subsequent upgrades. Please leave diagnostics on for now and send me a muso2.log if it happens.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Wed Sep 07, 2016 5:12 am

Here is what happened after your last post …

(a) When I ran muso on the first PC, I was automatically prompted to update, so I proceeded with the download and install. Following this, instead of muso running, I get an error “Unable to retrieve application files. Files corrupt in deployment”. So I ran muso again, and repeated the automatic update process. This time the upgrade was successful - now on Build 2.5.25.3. However I am back on a trial - the Machine ID was retained, but the license field is blank. I entered the license previously issued for this Machine ID and it was accepted. This PC is running Win10 Home 32Bit, Build 10586.545.

(b) When I ran muso on the second PC, I was not prompted for an update. So I quit and then restarted muso - this time I was prompted for an automatic update. After the update completed, but before muso restarted, I got the error “Windows cannot access the specified device path or file. You may not have the appropriate permissions to access them.”
Next time I started muso, I get the message “Application cannot be started. Contact the application vendor.”
Next I uninstalled muso, then downloaded muso (not stand alone installer) from the website. However the install fails with the same error “Windows cannot access the specified device path or file. You may not have the appropriate permissions to access them.”
I repeated the last step, after running “CCleaner” to clear all traces of muso from the registry - but get the same result.
After this I notice that my security software (Panda Free) has quarantined muso.exe, believing it to be a suspicious file. I restored the file and now muso runs. It tells me that my trial has expired. When I check the license, the Machine ID has changed to a previous ID, and the license field is blank. So I re-entered the appropriate license and it was accepted.
Now on muso Build 2.5.25.3. This PC is running Win10 Home 64Bit, build 10586.545.

(c) When I ran muso on the third PC, I was not prompted for an update. So I quit and then restarted muso - this time I was prompted for an automatic update. After the update completed, muso runs OK but indicates that my trial has expired. When I check the license, the Machine ID has not changed, but the license field is blank. So I re-entered the appropriate license and it was accepted. However when I go back to check the license window, the license field is blank again, but the Machine ID is retained. So next I quit and restart muso. Now the license is correctly displayed.
Now on muso Build 2.5.25.3. This PC is running Win10 Home 32Bit, build 10586.545.

So I have activated diagnostics logging on all 3 PC’s. If after the next update there are license problems, I will post a response here. I assume you don’t want log files posted here, so I will send them to your support email address.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby musoware » Wed Sep 07, 2016 6:15 am

OK thanks, there were more issues here than I anticipated - sorry for that.
I'll push another update now to force an upgrade, then we'll see if the licence and machine ID persist (that's one thing I dont understand about losing one not the other, since they are stored in the same place)
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Machine ID Changes With Every Update

Postby sonata » Wed Sep 07, 2016 6:31 am

Well I am for now just trying this on one PC.

The automatic update went OK, except after the update, it is still on Build 2.5.25.3. And diagnostics logging has been turned off?

Anyway I checked the license - the Machine ID was retained, but the license field is blank. So I re-entered the license and it was accepted.
So nothing seems to have changed.

As there is very little in the log, I will include it here ...
+----+--------------+---------+--------------------------------------------------------------------------------------------------------------------------------------------------------
| Th | Timestamp | Timing | Log Message
+----+--------------+---------+--------------------------------------------------------------------------------------------------------------------------------------------------------
| 01 | 03:57:33.802 | | muso version 2.5.25
| 01 | 03:57:33.802 | | Wednesday, 7 September 2016 3:57:33 PM
| 01 | 03:57:33.802 | | Diagnostics turned on
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Machine ID Changes With Every Update

Postby sonata » Wed Sep 07, 2016 6:37 am

I just realised that some of the log got lost when copying. Here is the complete log ...
+----+--------------+---------+--------------------------------------------------------------------------------------------------------------------------------------------------------
| Th | Timestamp | Timing | Log Message
+----+--------------+---------+--------------------------------------------------------------------------------------------------------------------------------------------------------
| 01 | 03:57:33.802 | | muso version 2.5.25
| 01 | 03:57:33.802 | | Wednesday, 7 September 2016 3:57:33 PM
| 01 | 03:57:33.802 | | Diagnostics turned on
| 01 | 03:58:20.664 | 046.855 | SaveMusicDB start
| 01 | 03:58:20.664 | | . no changes
| 01 | 03:58:20.664 | | SaveMusicDB end
| 01 | 03:59:20.681 | 060.009 | SaveMusicDB start
| 01 | 03:59:20.681 | | . no changes
| 01 | 03:59:20.681 | | SaveMusicDB end
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

PreviousNext

Return to Fixed (Archived)

Who is online

Users browsing this forum: No registered users and 1 guest

cron