Muso Filter and Genre Tag

Fixed bugs will be filed here.

Re: Muso Filter and Genre Tag

Postby sonata » Sun Aug 21, 2016 1:14 am

Yes, that is correct. But as soon as I switch to the Album Gallery view, it works as expected.

I have also noticed that sometimes when in the Database view, clicking the Wand icon does nothing, and when I examine the log, nothing is added to the log by that action. However as soon as I switch to the Album Gallery view and then click the Wand icon, tracks are queued.

As I can easily resolve the problem each time, I am not overly concerned by this anomaly.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Muso Filter and Genre Tag

Postby musoware » Sun Aug 21, 2016 5:14 pm

Oh I got it - the wand won't apply any change to the filter that you make AFTER switching to the DB view, if you filter first and then go to the DB view it does.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Muso Filter and Genre Tag

Postby sonata » Mon Aug 22, 2016 1:00 am

Well the behaviour is erratic. This morning when I tried it, the first thing I did was to change from the Album Gallery view to the DB view. Then I selected a genre from the filter list and then activated the Wand. A list appropriate to the genre was created.

So then remaining in the DB view, I cleared the queued list and then chose a different genre for the filter and again activated the wand - but no tracks were queued in the list, even though the filter was applied to the Database. I repeated these latter actions again, with the same result - no queued list was created.

Next I switched to the Album Gallery view. I selected a genre from the filter list and the Album Gallery changed accordingly. Then I activated the Wand and a queued list appropriate to the genre was created.

Next I returned to the DB view, activated the Wand and a queued list appropriate to the genre was created. But if if I change the filter while staying in the DB view, no queued list is created by the wand.

In summary, every thing works as expected if I stay in the Album Gallery view.

So the answer to your question in your last post is "yes" - except immediately after starting muso and switching to the DB view.

I hope this helps to clarify the problem.
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Re: Muso Filter and Genre Tag

Postby musoware » Mon Aug 22, 2016 8:04 am

Thanks, I'm sure that's enough for me to fix it.
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Muso Filter and Genre Tag

Postby musoware » Mon Aug 22, 2016 1:28 pm

Think I got it - version 2.5.22
musoware
Site Admin
 
Posts: 1816
Joined: Fri Sep 14, 2012 6:50 am

Re: Muso Filter and Genre Tag

Postby sonata » Tue Aug 23, 2016 5:52 am

Yes, I concur that the issue is fixed with V2.5.22 - thanks for your effort to resolve this.

Rob
sonata
 
Posts: 34
Joined: Mon May 02, 2016 5:33 am

Previous

Return to Fixed (Archived)

Who is online

Users browsing this forum: No registered users and 1 guest

cron